core.async

Dependency on clojurescript is introduced into clojure only projects

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Not Reproducible
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

When using core.async in a clojure only project, a dependency on Clojurescript is introduced.

Consider making the clojurescript dependency have "provided" scope, or moving it to a :dev profile.

Activity

Alex Miller added a comment -

Looks like this was already done - seems to be marked provided in pom and does not show up as transitive dependency in using project.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: