Clojure

Faster empty map creation, default to PersistentArrayMap when converting an obj-map whose lenght is less than cljs.core.PersistentArrayMap/HASHMAP_THRESHOLD

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Trivial Trivial
  • Resolution: Duplicate
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None
  • Patch:
    Code

Activity

Andy Fingerhut added a comment -

This patch appears to be for ClojureScript, not Clojure on the JVM. Unless there is a way to change the project that a ticket belongs to after it is created, a new ticket should be created for the ClojureScript project at the link below, and this ticket closed:

http://dev.clojure.org/jira/browse/CLJS

Nicola Mometto added a comment -

I couldn't find any way to move this to CLJS, so i created a new ticked (http://dev.clojure.org/jira/browse/CLJS-307)

This one can be closed, thanks Andy

Andy Fingerhut added a comment -

It wasn't when it was filed, but now it is a duplicate of CLJS-307

Andy Fingerhut made changes -
Field Original Value New Value
Resolution Duplicate [ 3 ]
Status Open [ 1 ] Closed [ 6 ]

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: