Clojure

update changes.md to include 1.5 changes

Details

  • Type: Task Task
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: Release 1.5
  • Component/s: None
  • Labels:
    None
  • Approval:
    Ok
  1. changes-draft-v10.md
    03/Dec/12 10:21 AM
    18 kB
    Timothy Baldridge
  2. changes-draft-v11.md
    03/Dec/12 1:59 PM
    18 kB
    Andy Fingerhut
  3. changes-draft-v5.md
    28/Nov/12 12:58 PM
    18 kB
    Christopher Redinger

Activity

Andy Fingerhut added a comment -

changes-draft-v1.md is not a patch, but an outline of a proposed new changes.md file for Clojure 1.5 with some of the content fleshed out. It still has lots of occurrences of "TBD" for "To Be Documented" in it.

It does mention every ticket that had a patch committed since Clojure 1.4.0 until Nov 15 2012.

I am hoping someone who is more knowledgeable of the "TBD" parts takes this and runs with it.

Andy Fingerhut made changes -
Field Original Value New Value
Attachment changes-draft-v1.md [ 11680 ]
Andy Fingerhut added a comment -

changes-draft-v2.md is very similar to the earlier changes-draft-v1.md described above, but has a few additions.

Andy Fingerhut made changes -
Attachment changes-draft-v2.md [ 11699 ]
Andy Fingerhut made changes -
Attachment changes-draft-v1.md [ 11680 ]
Stuart Halloway made changes -
Assignee Timothy Baldridge [ halgari ]
Timothy Baldridge added a comment -

V3 of the draft...should be almost good to go. Someone with more info on reducers should take a look at that section as have yet to actually use them much.

Timothy Baldridge made changes -
Attachment changes-draft-v3.md [ 11711 ]
Andy Fingerhut made changes -
Attachment changes-draft-v2.md [ 11699 ]
Andy Fingerhut added a comment -

Removed V2 of the draft as Timothy's V3 had all of it and more.

Timothy Baldridge added a comment -

Fleshed out the reducers section a bit.

Timothy Baldridge made changes -
Attachment changes-draft-v4.md [ 11715 ]
Timothy Baldridge made changes -
Attachment changes-draft-v3.md [ 11711 ]
Timothy Baldridge added a comment -

Alright, I think this is ready for a final review by someone besides me.

Christopher Redinger added a comment -

Editorial cleanup

Christopher Redinger made changes -
Attachment changes-draft-v5.md [ 11718 ]
Andy Fingerhut added a comment -

Christopher, isn't this file intended to be in Markdown format, not HTML?

Christopher Redinger made changes -
Attachment changes-draft-v5.md [ 11718 ]
Christopher Redinger added a comment -

uploading the correct md file

Christopher Redinger made changes -
Attachment changes-draft-v5.md [ 11719 ]
Timothy Baldridge made changes -
Attachment changes-draft-v4.md [ 11715 ]
Timothy Baldridge made changes -
Approval Vetted [ 10003 ] Screened [ 10004 ]
Andy Fingerhut added a comment -

changes-draft-v6.md same as v5, except for a couple of spelling corrections.

Andy Fingerhut made changes -
Attachment changes-draft-v6.md [ 11720 ]
Timothy Baldridge added a comment -

Missing desc on when->. Fixed in v7 of the doc

Timothy Baldridge made changes -
Attachment changes-draft-v7.md [ 11723 ]
Andy Fingerhut made changes -
Attachment changes-draft-v6.md [ 11720 ]
Rich Hickey added a comment -

"1.1 Clojure 1.5 requires Java 1.6 or later"

did you mean "building Clojure 1.5"?

I don't know that anything requires 1.6

Rich Hickey added a comment -

test->, let-> when->

are now:

cond->, as-> and some->

Andy Fingerhut added a comment -

I'll put up an updated version soon, but that headline wasn't properly updated to match the later occurrence of it in the body, which is: "Clojure 1.5 reducers library requires Java 6 or later". Is it true that the ForkJoin library requires Java 6 or later? If not, how can it be made to work with Java 5?

Andy Fingerhut added a comment -

changes-draft-v8.md updates the table of contents headings to match those in the body, and updates names of new threading macros.

Andy Fingerhut made changes -
Attachment changes-draft-v8.md [ 11736 ]
Steve Miner added a comment -

changes-draft-v8.md, section 2.4, needs an update for description of some->. The document says "logical true" where it should say "not nil". Same comment applies to some->>. The point is that false will thread through the forms. This is a change from the replaced when-> (in 1.5-beta1).

Timothy Baldridge added a comment -

updated to reflect changes to some-> and some->>

Timothy Baldridge made changes -
Attachment changes-draft-v9.md [ 11738 ]
Steve Miner added a comment -

Sorry to nit pick, but there are two more "logical true" phrases in v9 that need to change to "not nil" in those some-> and some->> descriptions.

Timothy Baldridge made changes -
Attachment changes-draft-v10.md [ 11739 ]
Timothy Baldridge made changes -
Attachment changes-draft-v9.md [ 11738 ]
Timothy Baldridge made changes -
Attachment changes-draft-v7.md [ 11723 ]
Timothy Baldridge added a comment -

Not a problem. Thanks for looking it over!

Andy Fingerhut made changes -
Attachment changes-draft-v8.md [ 11736 ]
Stuart Halloway added a comment -

I find the following sentence a little vague: "Clojure 1.5 can still be compiled and run with Java 5, but the test suite will not pass due to the lack of support for ForkJoin."

The problem is the application of the "but" to both parts of the conjunction. Isn't the intent actually: "Clojure can run with Java version 1.5 or later. Running the Clojure build requires 1.6, in order to test features that work with ForkJoin."

Andy Fingerhut added a comment -

Stuart H, that is almost the intent, and probably close enough for this kind of documentation.

The full gory details are as follows:

Clojure can build and run with Java version 1.5 or later. A Java version 1.5 build of Clojure only works if you do not run the test suite, e.g. by using the command "ant jar". To build Clojure including running the test suite, or to use the new reducers library, requires Java 1.6 or later.

If the patch for CLJ-1109 is applied, the full gory details become simpler to state:

Clojure can build and run with Java version 1.5 or later. Using the new reducers library requires Java 1.6 or later.

Andy Fingerhut added a comment -

changes-draft-v11.md changes the description of Java 5 limitations to match the current gory details, and hopefully address Stuart H's concerns raised above.

Andy Fingerhut made changes -
Attachment changes-draft-v11.md [ 11744 ]
Rich Hickey made changes -
Approval Screened [ 10004 ] Ok [ 10007 ]
Stuart Halloway made changes -
Resolution Completed [ 1 ]
Status Open [ 1 ] Closed [ 6 ]

People

Vote (0)
Watch (2)

Dates

  • Created:
    Updated:
    Resolved: