Clojure

various clojure.core functions with ^:static metadata are missing doc strings

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Trivial Trivial
  • Resolution: Declined
  • Affects Version/s: Release 1.6
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

Several functions defined with legacy ^:static metadata are not shown in API documentation. Examples are chunk-cons or await1. This defect probably originates in autodoc.

Activity

Tom Faulhaber added a comment -

These functions have no doc strings. Autodoc doesn't include Vars without documentation by design.

I'll leave it to others to decide if the functions should have doc strings or not. If they are meant for general use, I would say that the answer is "yes."

Tom Faulhaber made changes -
Field Original Value New Value
Summary functions with ^:static metadata are not present in API documentation various clojure.core functions with ^:static metadata are missing doc strings
Alex Miller added a comment -

The autodoc behavior is intentional. The omission of docstrings is intentional (these are internal functions).

Alex Miller made changes -
Resolution Declined [ 2 ]
Status Open [ 1 ] Closed [ 6 ]

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: