Clojure

Bug: Compile-time NPE on set! of non-existent field [for 1.0]

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Resolution: Duplicate
  • Affects Version/s: None
  • Fix Version/s: Backlog
  • Component/s: None
  • Labels:
    None

Description

The bug described in #142 also exists in Clojure 1.0.0

Activity

Assembla Importer added a comment -
Assembla Importer added a comment -

chouser@n01se.net said: Parent association with ticket #142 was added

Alexander Redington added a comment -

This duplicate of #142 has been resolved.

Latest from head:

user=> (set! (.foo "fred") 47)
IllegalArgumentException No matching field found: foo for class java.lang.String clojure.lang.Reflector.setInstanceField (Reflector.java:257)
user=>


People

  • Assignee:
    Unassigned
    Reporter:
    Anonymous
Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: