Clojure

Inconsistent behavior in transient sets: they should allow contains?

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Duplicate
  • Affects Version/s: Release 1.6, Release 1.8
  • Fix Version/s: None
  • Component/s: None
  • Labels:
  • Patch:
    Code and Test

Description

Transient maps and sets retain the behavior of persistent maps and sets.

When threading operations on transient sets, it is unfortunately impossible to test for membership, since the implementation of contains? defers to contains in clojure.lang.RT which does not

There are several solutions for this, I chose to extend contains in clojure.lang.RT to handle ITransientSet

Activity

Alex Miller added a comment -

Dupe of CLJ-700


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: