Clojure

[PATCH] embedded constants

Details

  • Type: Enhancement Enhancement
  • Status: Closed Closed
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: Release 1.1
  • Component/s: None
  • Labels:
    None
  • Approval:
    Ok

Description

clojure.lang.Compiler.FnExpr now handles primitives

Activity

Assembla Importer added a comment -

timothypratley said: [file:bWpR2kFXmr3RkXeJe5aVNr]

Assembla Importer added a comment -

timothypratley said: [file:cwL30uFXmr3ORSeJe5afGb]: tests

Assembla Importer added a comment -

timothypratley said: Hi Rich,

Just curious if you've had a chance to look at this patch yet - please be honest if it has shortfallings so I can improve. I suspect that my vim setup might have formatting differences - if that is the case I'm happy to use Aquamacs or whatever is preferred.

Also I get the feeling this is only a small part of the change required, and I don't grok what the other part is (some print-dup change?)... so some guidance would be appreciated.

Regards,
Tim.

Assembla Importer added a comment -

chouser@n01se.net said: Tim,

Would you be willing to reformat the tests you wrote as a patch to clojure.test-clojure? That way they'll be included in the regression runs done for future patches.

Assembla Importer added a comment -

timothypratley said: [file:cm6M6gRi4r3RdbeJe5afGb]: patch to clojure-test

Assembla Importer added a comment -

timothypratley said: [file:aV1YJARjyr3RdbeJe5afGb]: Here is a better test, shorter and stronger

Assembla Importer added a comment -

timothypratley said: Hi Chris

Good idea, I've uploaded a patch to clojure-tests/compilation.clj
Please use the last file attached:
embedded-constants-tests2.diff

Regards,
Tim.

Assembla Importer added a comment -

timothypratley said: (In [[r:86d8a952daee73bf7b7b0c5a41c7ad3faf27c038]]) embedded constants, refs #164

Primitive Class objects are now handled explicitly
eg: (eval `(make-array ~Byte/TYPE 2))

Signed-off-by: Chouser <chouser@n01se.net>

Branch: master

Assembla Importer added a comment -

timothypratley said: (In [[r:b044959a42f5f58a37c4151f4d7b6652e17348ab]]) added tests, fixes #164

Signed-off-by: Chouser <chouser@n01se.net>

Branch: master

Assembla Importer added a comment -

chouser@n01se.net said: I think I must have been in the process of checking and submitting the first test patch when you attached the second. I'll swap them later.

Assembla Importer added a comment -

timothypratley said: [file:a2gi08RpSr3PSLeJe5afGb]: Might be easier to apply - based to current head

Assembla Importer added a comment -

timothypratley said: No worries, this is really great for me - getting used to the whole process - thanks. I've uploaded a diff from the current head to save you some minor headaches I hope.

Assembla Importer added a comment -

timothypratley said: (In [[r:1ca9c8b9322882a0d84db9007047d223d11f2c3f]]) shorter, stronger embedded-constants tests. fixes #164

Signed-off-by: Chouser <chouser@n01se.net>

Branch: master

Assembla Importer added a comment -

timothypratley said: [file:b5AX0uRUir3OwbeJe5aVNr]: Ok this time for sure! How embarassing - the last patch didn't actually test anything due to misplaced parenthesis

Assembla Importer added a comment -

timothypratley said: How embarrassing - I had a misplaced parenthesis in my patch which meant the test didn't do anything

Assembla Importer added a comment -

timothypratley said: [file:dngmRARUur3OwbeJe5aVNr]: Based to current git HEAD

Assembla Importer added a comment -

richhickey said: Isn't this in already? Or is the discussion now about the tests?

Assembla Importer added a comment -

timothypratley said: (In [[r:5f9df70163bd9c7a168c1ef8cd2be67651401f29]]) Fixed broken test-embedded-constants. Fixes #164

Signed-off-by: Chouser <chouser@n01se.net>

Branch: master

Assembla Importer added a comment -

timothypratley said: Yes that's right there was just that test issue but its all sorted out now thanks very much.


People

  • Assignee:
    Chouser
    Reporter:
    Anonymous
Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: