Clojure

GC Issue 58: `() gives strange compiler error (i.e. backquote of empty list)

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

Reported by tuomas.lukka, Jan 29, 2009

What (small set of) steps will reproduce the problem?

Run the code `()   

What is the expected output? What do you see instead?

I'd expect it to return a quoted empty list. Instead an error results:

Exception in thread "main" java.lang.UnsupportedOperationException: Unknown
Collection type (test.clj:1)
 at clojure.lang.Compiler.load(Compiler.java:4476)
 at clojure.lang.Compiler.loadFile(Compiler.java:4437)
 at clojure.lang.Script.main(Script.java:65)
Caused by: java.lang.UnsupportedOperationException: Unknown Collection type
 at clojure.lang.LispReader$SyntaxQuoteReader.syntaxQuote(LispReader.java:711)
 at clojure.lang.LispReader$SyntaxQuoteReader.invoke(LispReader.java:655)
 at clojure.lang.LispReader.read(LispReader.java:143)
 at clojure.lang.Compiler.load(Compiler.java:4466)
 ... 2 more

What version are you using?

20081217

Was this discussed on the group? If so, please provide a link to the
discussion:

no

Please provide any additional information below.

Comment 1 by richhickey, Feb 09, 2009
fixed in svn 1255 - thanks for the report
Status: Fixed

Activity

Assembla Importer added a comment -

People

  • Assignee:
    Unassigned
    Reporter:
    Anonymous
Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: