Clojure

agent self-send test heisenfailing

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: Release 1.3
  • Component/s: None
  • Labels:
    None
  • Approval:
    Ok

Description

The commented-out test (https://github.com/clojure/clojure/commit/605944b7f667e9fdcc2a380c5dd07304118dca34) is failing intermittently. If you are working on this, look at the changes made in CLJ-672, which may be related.

Activity

Alexander Redington added a comment -

My initial research today suggests this might more likely be an issue with await-for than agent error handlers. After examining a couple of different variants of the offending test, I've found that:

  • The test won't fail without await-for returning due to timing out
  • The test won't fail if we substitute await for await-for
  • The test won't fail without await-for returning due to timing out
  • The test won't fail if we substitute await for await-for
Stuart Halloway added a comment -

Alex: you didn't try hard enough to reproduce – you can make it happen even with await.

But you diagnosis got me on the right track to fixing this. Thanks! Patch in a moment.

Stuart Halloway added a comment -

The original tests had a race condition: you can't use await to wait on agent actions triggered from another thread. Improved version of the tests uses a CountdownLatch.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: