Clojure

Adds support for FreeDesktop's xdg-open in clojure.java.browse/browse-url.

Details

  • Type: Enhancement Enhancement
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Completed
  • Affects Version/s: Release 1.3
  • Fix Version/s: None
  • Component/s: None
  • Labels:
  • Environment:
    Any environment that supports FreeDesktop, so Linux and BSD mainly.
  • Patch:
    Code

Description

This patch allows environments that support FreeDesktop to browse a URL in their default browser. This is important because unless the desktop environment bridges to Java (like Gnome does) the URL will be opened in a Swing window, which is not always desired.

See: https://github.com/clojure/clojure/pull/14

Activity

Jeremy Heiler made changes -
Field Original Value New Value
Attachment browseurl.patch [ 10792 ]
Andy Fingerhut added a comment -

Is this a duplicate of CLJ-896? Can you look at the patch there and see if there is any advantage to the patch for it vs. the one here? Or perhaps some combination that is an improvement on them both?

Andy Fingerhut added a comment -

The issue is definitely a duplicate of CLJ-896. The proposed patches were different. CLJ-896 now has an attached patch that is an enhancement of what Jeremy Heiler created.

Andy Fingerhut made changes -
Resolution Completed [ 1 ]
Status Open [ 1 ] Resolved [ 5 ]
Stuart Halloway made changes -
Status Resolved [ 5 ] Closed [ 6 ]

People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: