Clojure

after call to clojure.java.shell/sh, jvm won't exit

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Duplicate
  • Affects Version/s: Release 1.3, Release 1.4
  • Fix Version/s: None
  • Component/s: None
  • Labels:
  • Environment:
    Reproduced on Ubuntu using Sun Java 1.6, OpenJDK 1.6, and Sun Java 1.7

Description

Create the following four-line file, shell_example.clj:

;; simple example of call to sh that causes jvm to hang after print
(require '[clojure.java.shell :as shell])
(shell/sh "ls")
(println "jvm should exit after this, but it doesn't")

Run:
java -jar clojure-1.3.0.jar shell_example.clj

After the message is printed, the jvm doesn't quit. It just sits there. I have to hit Ctrl-C to force the jvm to quit.

This happens on 1.3 and the most recent code in github as of 3/26/2012. I imagine the jvm is waiting for a thread that hasn't terminated, but the code in the sh function doesn't look like it's doing anything obviously wrong. I'm too much of a newcomer to Clojure to dig any deeper.

My workaround right now is to do (System/exit 0) to force the jvm to quit.

Thank you for your work on Clojure, it's simply an amazing language.

Activity

Andy Fingerhut added a comment -

Jeff, this occurs in any Clojure program where certain threading mechanisms are invoked. In your case, clojure.java.shell/sh uses future, which causes threads to be created that then sit around for about 60 seconds after everything else quits, and the main Java process does not exit until that happens. Another way to get the program to exit quickly is to call (shutdown-agents), but that isn't any more convenient than (System/exit 0), nor is there any obvious way you can tell as a newcomer that you should be doing this.

The ticket CLJ-124 is marked with status "Approved" at this time, which leads me to believe that perhaps soon there will be a change made to Clojure such that this situation will change.

Andy Fingerhut added a comment -

This behavior is now documented on clojuredocs.org for future, and both pmap and clojure.java.shell/sh refer to future for details.

Alex Miller added a comment -

This ticket is effectively a duplicate of CLJ-120 regarding shutdown properties after use of future/agent (sh uses future). Can't see any purpose in leaving this open.

Andy Fingerhut added a comment -

That would be CLJ-124, not CLJ-120 as stated in the previous comment, in case anyone wants to follow the links later. A bit confusing since CLJ-124 has a summary description with 120 in it.


People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: