ClojureCLR

Clojure.Compile treats compile path of "." as the Clojure install path

Details

  • Type: Defect Defect
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None
  • Environment:
    ClojureCLR 1.3.0 on Windows 7.

Description

When I run Clojure.Compile.exe on a .clj file in the current directory, it claims that it is "Compiling program to .", but no assemblies appear. After a bit of searching, I discovered that the output assemblies are being dropped into the directory containing Clojure.Compile.exe!

(This is a duplicate of https://github.com/richhickey/clojure-clr/issues/55, but it's unclear whether we should report things here or there.)

Activity

David Miller added a comment -
Neal Groothuis added a comment - - edited

Ah-ha: it appears that this is a duplicate of https://github.com/richhickey/clojure-clr/issues/52, and the behavior was changed in e002ef3. However, it still appears to be at odds with the desired behavior noted at http://clojureclr.blogspot.com/2012/01/compiling-and-loading-in-clojureclr.html; i.e., *compile-path* is still being ignored.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: