ClojureScript

align standard out printing behavior with Clojure

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

The behavior and print and println do not mirror Clojure's. This makes figuring out how to print to standard out consistently a bit of guessing game. The fixes in CLJS-340 have changed the output of the benchmarks which made me notice that the issue is pervasive.

To see the basic issue run ./script/benchmark before and after the CLJS-340 fix.

Activity

Evan Mezeske added a comment -

Attaching a patch that fixes the double-newline regression. It was a typo on my part.


People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: