ClojureScript

copy cond-> etc from 1.5

Details

  • Type: Enhancement Enhancement
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None
  • Patch:
    Code

Description

Attached patch (cljs-438-condetc.patch, 11 Dec 2012) copies cond->, cond->>, as->, some->, and some->> from 1.5 master. This lets ClojureScript users use these macros without requiring Clojure 1.5.

I suppose this maybe should wait until 1.5.0 is out, in case another renaming occurs.

Another way to do this would be to have import-macros ignore missing macros and add these there. Then the macros would only be available for users requiring Clojure 1.5 (which.. makes sense), and we wouldn't have to copy them.

Activity

People

  • Assignee:
    Unassigned
    Reporter:
    Tom Jack
Vote (0)
Watch (3)

Dates

  • Created:
    Updated:
    Resolved: