ClojureScript

ClojureScript places fully qualified keywords in the user namespace

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

(ns testns)

(pr-str "kw: " ::kwtest " ns: " (namespace ::kwtest))
==> ("kw: " :user/kwtest "ns: " "user")

while in clojure:
(ns testns)

(pr-str "kw: " ::kwtest " ns: " (namespace ::kwtest))
==> ("kw: " :testns/kwtest "ns: " "testns")

Activity

David Nolen added a comment -

duplicate of CLJS-74

Jeremy Hughes added a comment -

This affects more than just the repl.

Radford Smith added a comment -

Yeah, this seems to happen in normally compiled code. Am I missing something or does this need to be reopened?

David Nolen added a comment -

So you see the correct behavior at the REPL but not compiled code?


People

Vote (0)
Watch (2)

Dates

  • Created:
    Updated:
    Resolved: