ClojureScript

multiple arity defn conflicts with namespace

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None
  • Environment:
    clojure 1.5.1
    lein-cljsbuild 0.3.2

Description

foo.cljs:

(ns foo)

(defn f [x] x)

bar.cljs:

(ns bar
  (:require foo))

(defn foo
  ([] (foo nil))
  ([x] x))

When compiled in :whitespace mode, js output is incorrect. See attached zip for minimal(ish) example.

Activity

Jozef Wagner added a comment -

a possible duplicate of CLJS-456 ?

David Nolen added a comment -

Yes this appears to dupe CLJS-456. However, we should use this as one of thee test cases. Let's keep this open until CLJS-456 gets closed.

David Nolen added a comment -

It appears this bug is different from CLJS-456, for some reason self calls are not fully qualified?


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: