ClojureScript

Null pointer exception from using the "when" function in extend-type macro

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None
  • Environment:
    Mac OSX
  • Patch:
    Code

Description

Was writing a patch to fix CLJS-528, but am getting a null pointer exception from using the when function in the extend-type macro.

Activity

Rupa Shankar added a comment -

The code that produces the null pointer exception – using when-not does not, but using when (as the patch currently does) does produce the exception.

Rupa Shankar made changes -
Field Original Value New Value
Attachment 624.patch [ 12336 ]
David Nolen added a comment -

this is not a bug in ClojureScript itself, the patch will allow nils to flow into analyzer/resolve-var which won't work, because (namespace nil) will throw.

David Nolen made changes -
Resolution Completed [ 1 ]
Status Open [ 1 ] Resolved [ 5 ]
David Nolen made changes -
Status Resolved [ 5 ] Closed [ 6 ]

People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: