ClojureScript

script/bootstrap downloads unspecified version of closure-compiler

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Declined
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

script/bootstrap downloads http://dl.google.com/closure-compiler/compiler-latest.zip (https://github.com/clojure/clojurescript/blob/r2080/script/bootstrap#L64), while the project.clj specifies a specific version.

As a result, you'll get a different version of the compiler when using following the Quick Start guide. The latest version of the Closure Compiler was compiled for Java 7, causing cljsc to fail with a java.lang.UnsupportedClassVersionError under Java 6.

Activity

People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: