ClojureScript

cljs.closure/source-on-disk inconsistency

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None
  • Environment:
    clojurescript with source maps
  • Patch:
    Code

Description

cljs.closure/source-on-disk will ensure that all source files are available when source maps are enabled. Sources from jar files are copied and reference the target location afterwards, sources on the filesystem are copied BUT the reference to that location is lost.

The attached patch ensures that the correct url is used in cljs.closure/output-unoptimized since otherwise the source maps will contain links to invalid files, assuming the source files are not on :source-map-path.

Activity

Thomas Heller added a comment -

Oops this breaks some other cases, working on a fix.

Thomas Heller added a comment -

Ok the issue is a lot more involved than I had hoped but I uncovered a bug while looking into it. Basically CLJS expects javascript files in jars never to change, it at least wont try to copy it again so the source map might be incorrect if a javascript file inside a jar changes.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: