ClojureScript

tool.reader can't handle white-space

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
  • Environment:
    MBP running lion 10.7.5

Description

I believe the tool.reader (may some other part of ClojureScript) cannot handle a file with a large amount of white space. I have a cljx generated file with nothing but a namespace and about 300-400 lines of white-space. The entire file is simply a namespace and whitespace (file attached shows white-space in red). I get a stackoverflow error arising mainly from clojure.tools.reader$read.invoke(reader.clj:727). I have screenshots of the beginning and end of the stackoverflow attached. If I remove the whitespace, ClojureScript will compile, which leads me to believe it is the white space that is the cause of the issue.

Activity

Nicola Mometto added a comment -

Attached a patch that bumps tools.reader to the lastest version (0.8.3)

Can you apply this and verify that it solves the issue?

Remeber you'll have to clean the lib/ folder form old tools.reader jars.

Nicola Mometto added a comment -

Updating to tools.reader >=0.8.1 should fix this issue.


People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: