ClojureScript

Hashing issue in Mobile Safari clients

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Duplicate
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

Duplicate key errors occurring in Mobile Safari client no minimal case as of yet.

Activity

Thomas Heller added a comment - - edited

I made a list of affected User Agents sending me maps with duplicate keys.

Full List available here:
https://gist.github.com/thheller/8cae79cabd9ac74958ca
WARNING: That is a list of ALL user agents that send me a map with duplicate keys. Some of those are from cljs-2268, but the mobile versions definitly still have this problem on 2277. Will try to make a better list. The examples below are from 2277 though.

Examples:
Mozilla/5.0 (iPad; CPU OS 7_1_2 like Mac OS X) AppleWebKit/537.51.2 (KHTML, like Gecko) Version/7.0 Mobile/11D257 Safari/9537.53
Mozilla/5.0 (iPhone; CPU iPhone OS 7_1_2 like Mac OS X) AppleWebKit/537.51.2 (KHTML, like Gecko) Version/7.0 Mobile/11D257 Safari/9537.53
Mozilla/5.0 (Linux; U; Android 4.1.2; de-de; GT-N8010 Build/JZO54K) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Safari/534.30

David Nolen added a comment - - edited

Are you sure this isn't because clients have cached versions of your script this looks exactly like this bug: https://bugs.webkit.org/show_bug.cgi?id=126345. Mobile clients tend to have aggressive script caching policies.

Thomas Heller added a comment -

Yes, definitly not a cache issue. JS files are versioned. Just tried in Private Mode after wiping the cache. Still able to reproduce it.

I can give you an URL and a step-by-step if you want to try it. Its not exactly minimal but its better than nothing.

David Nolen added a comment -

Please do, I'd prefer to get this resolved before cutting another release. Thanks.

Thomas Heller added a comment -

CLJS-839, duplicate Issue with a minimal example!


People

Vote (0)
Watch (2)

Dates

  • Created:
    Updated:
    Resolved: