ClojureScript

Different behaviour for read-string in clojure and clojurescript

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Declined
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
  • Environment:
    Clojure 1.6.0
    ClojureScript 2280

Description

The following works in clojure: (read-string "{:weapons (:20)}")
But gives following error in cljs: "TypeError: Cannot read property '0' of null"

Activity

Francis Avila added a comment -

Duplicate of CLJS-677.

David Nolen added a comment -

As far as I know this is not supported see the reader page on clojure.org

David Nolen made changes -
Field Original Value New Value
Resolution Completed [ 1 ]
Status Open [ 1 ] Resolved [ 5 ]
David Nolen made changes -
Status Resolved [ 5 ] Reopened [ 4 ]
Resolution Completed [ 1 ]
David Nolen made changes -
Resolution Declined [ 2 ]
Status Reopened [ 4 ] Resolved [ 5 ]
David Nolen made changes -
Status Resolved [ 5 ] Closed [ 6 ]

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: