Clojure-Contrib

AOT of logging.clj causes logging implementation to be decided at compile-time

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Resolution: Declined
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

We shouldn't AOT logging.clj since this causes the log implementation to be determined at compile-time. This is almost always the wrong thing; it should be determined at load-time since it's determined by what classes are on the classpath at runtime.

Activity

Assembla Importer added a comment -

technomancy said: [file:aqNkDi9byr3Rn8eJe5aVNr]: A patch to build.xml

Assembla Importer added a comment -

technomancy said: Oops; dupe of #44.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: