Clojure-Contrib

fix pprint tests and reenable

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

Apparently (according to ticket 65), someone has broken the pprint tests, presumably during the switch to maven and all the hacking to get around gen-class/maven bugs.

Take a look at this and fix it.

Activity

Assembla Importer added a comment -

stuart.sierra said: Never mind, it was a simple typo in the gen_class.clj file. Nothing to do with pprint or with the build process.

Tests re-enabled; all pass.

Assembla Importer added a comment -

stuart.sierra said: (In revision:5b3beaed9ef8520c8c1e09ff7ac5b817786f51e2) Fix mis-named ns in pprint.gen-class; refs #66

Branch: master

Assembla Importer added a comment -

stuart.sierra said: I don't think this was caused by changes in the build. Something has changed about how arguments get passed to init functions. The ColumnWriter init function is getting the same arguments as the PrettyWriter init function (a Writer, 72, and 40).

Assembla Importer added a comment -

stuart.sierra said: It appears that the ColumnWriter/-init function is getting called with 3 arguments.

Assembla Importer added a comment -

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: