data.json

data.json does not AOT

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Declined
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

When trying to AOT data.json I get the following exception:

CompilerException java.lang.ClassNotFoundException: 
clojure.data.json.JSONWriter, compiling:(clojure/data/json.clj:279:1)

I encountered this problem while looking into the possibility of AOTing the ClojureScript compiler to avoid startup time issues. ClojureScript now depends on data.json to help with source maps - so this was the first AOT hurdle I encountered.

The exact steps I take to reproduce the bug:

  • fresh checkout of ClojureScript
  • ./script/bootstrap
  • mkdir classes
  • ./script/repl
  • (compile 'clojure.data.json)

Activity

Stuart Sierra added a comment -

Marking old issues as 'closed'

David Nolen added a comment -

Not a bug


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: