core.logic

nominal, spurious nil

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Declined
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

(nth
    (run 2 [q]
      (nom/fresh [a0 a1]
        (redo* q `((~'fn ~(nom/tie a0 a0)) (~'fn ~(nom/tie a1 a1))))))
    1) ; => ((fn  [a_0] (quote ((fn  [a_1] a_1) (fn  [a_2] a_2)))) nil)

Activity

Nada Amin added a comment -

Not a bug

Nada Amin added a comment -

Oh, this is actually correct.
nil is a value in our mini-language, so this applies the first function to nil, but then doesn't use it, and just returns the requested result quoted.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: