tools.analyzer

Add more ex-data to exceptions thrown when validate-tag cannot find class

Details

  • Type: Enhancement Enhancement
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Completed
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

This is useful for lint tools like Eastwood, or any others that wish to provide more detailed error messages that help a developer learn the reason that their code cannot be analyzed.

Activity

Andy Fingerhut added a comment -

Patch tanal-32-v1.diff is one way to achieve this. The ast node containing the failed-to-validate tag is the most useful. The :tag-kind can help the caller a bit in distinguishing the cause of the exception.


People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: