tools.analyzer

t.a(.jvm) throw exception during analysis of namespace clojure.core.async.impl.channels due to ^int type hint on constant

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Duplicate
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None

Description

To reproduce with latest t.a(.jvm) and Eastwood:

$ cd path/to/core.async
$ lein eastwood '{:namespaces [ clojure.core.async.impl.channels ]}'

The exception is no longer thrown if you remove the int type hint from MAX-QUEUE-SIZE in the namespace where it is defined.

This type hint was there in core.async since August 2013, so earlier versions of t.a(.jvm) were not throwing this exception with this code, I am pretty sure.

Activity

Nicola Mometto added a comment -

People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: