<< Back to previous view

[NREPL-7] Dependency on 1.3.0-master-SNAPSHOT instead of 1.3.0 Created: 15/Nov/11  Updated: 15/Nov/11  Resolved: 15/Nov/11

Status: Closed
Project: tools.nrepl
Component/s: None
Affects Version/s: None
Fix Version/s: None

Type: Defect Priority: Minor
Reporter: Steve Lindsay Assignee: Chas Emerick
Resolution: Completed Votes: 0
Labels: None


 Description   

Running "mvn install" on tools.nrepl results in a build failure:

[INFO] Missing:
[INFO] ----------
[INFO] 1) org.clojure:clojure:jar:1.3.0-master-SNAPSHOT

Changing 1.3.0-master-SNAPSHOT to 1.3.0 in src/integration/clojure-1.3.0/pom.xml seems to fix it.



 Comments   
Comment by Chas Emerick [ 15/Nov/11 5:13 AM ]

Bizarre, since it is building cleanly here and on build.clojure.org.

I should certainly update the version number in that pom to 1.3.0 though. I'll do that shortly.

FWIW, maybe adding a -U to your mvn invocation would help? That forces a check of all snapshots.

Comment by Chas Emerick [ 15/Nov/11 5:22 AM ]

fixed on HEAD

Generated at Fri Oct 31 11:40:18 CDT 2014 using JIRA 4.4#649-r158309.