core.cache

Can't evict on LIRS cache

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Duplicate
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None
  • Environment:
    clojure 1.8.0
    org.clojure/core.cache 0.6.5

Description

Reproduce with :

(-> (cache/lirs-cache-factory {})
    (cache/miss :a 1)
    (cache/evict :a))

Throws this :

AbstractMethodError Method clojure/core/cache/LIRSCache.evict(Ljava/lang/Object;)Ljava/lang/Object; is abstract clojure.core.cache.LIRSCache (cache.clj:-1)

Activity

Sean Corfield added a comment -

Duplicate of CCACHE-11.

Sean Corfield added a comment -

Release 0.7.0


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: