ClojureScript

Update aot_core to support build with MINGW on Windows

Details

  • Type: Enhancement Enhancement
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Completed
  • Affects Version/s: 1.9.76
  • Fix Version/s: 1.9.854
  • Component/s: None
  • Labels:
  • Environment:
    Windows 10
  • Patch:
    Code
  • Approval:
    Accepted

Description

When using Git Bash (which uses MINGW), ./script/build can get nearly all the way through it's work. However, it dies in aot_core because of the way that the classpath is generated by the Maven dependency:build-classpath plugin.

Activity

Thomas Kidd added a comment -

I was able to get this working locally, and will submit a patch when I am sure things are working

Thomas Kidd added a comment -

Updates aot_core to set the classpath correctly. More comments in patch.

Thomas Kidd added a comment -

Tested that patched version of master works on Windows 10 and OSX

Thomas Kidd added a comment -

Needs review

David Nolen added a comment -

Issues don't get closed until the issue is actually resolved


People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: