ClojureScript

cljs.test ignores some deftest names

Details

  • Type: Defect Defect
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Not Reproducible
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
  • Environment:

Description

examples:

  • ignores: (deftest test:change-step-contiguous-forward> ....)
  • works: (deftest test:change-current-step ...) ignores: (deftest test-change-current-step ...)

Activity

David Nolen added a comment -
(deftest test:change-current-step: ...)
(deftest test:change-current-step@ ...)

Removed these two from ticket description these are not valid Clojure symbols see http://clojure.org/reader

Show
David Nolen added a comment -
(deftest test:change-current-step: ...)
(deftest test:change-current-step@ ...)
Removed these two from ticket description these are not valid Clojure symbols see http://clojure.org/reader
David Nolen added a comment -

I tested the remaining names could not reproduce. Please only reopen this ticket if a full minimal case is provided.


People

Vote (0)
Watch (1)

Dates

  • Created:
    Updated:
    Resolved: