math.combinatorics

WARNING: clojure.math.combinatorics/lex-permutations is deprecated. at line 278 resources\test\out\clojure\math\combinatorics.cljc

Details

  • Type: Defect Defect
  • Status: Open Open
  • Priority: Minor Minor
  • Resolution: Unresolved
  • Affects Version/s: None
  • Fix Version/s: None
  • Component/s: None
  • Labels:
    None
  • Environment:
    ClojureScript 1.9.908 compiled with Clojure 1.8.0

Description

These three WARNINGs appear when using this library:

```
WARNING: clojure.math.combinatorics/lex-permutations is deprecated. at line 278 resources\test\out\clojure\math\combinatorics.cljc
WARNING: clojure.math.combinatorics/lex-permutations is deprecated. at line 285 resources\test\out\clojure\math\combinatorics.cljc
WARNING: clojure.math.combinatorics/lex-permutations is deprecated. at line 289 resources\test\out\clojure\math\combinatorics.cljc
```
This is a trivial fix, and it would be nice to avoid having these warnings. Thank you all!

Activity

Hide
Mark Engelberg added a comment -

lex-permutations is deprecated for external use, but is still valid as a private function within that namespace, used as a helper function by the public functions. I've never seen this warning in Clojure. Is this a Clojurescript bug, improperly applying the warning to private calls to a deprecated function?

Show
Mark Engelberg added a comment - lex-permutations is deprecated for external use, but is still valid as a private function within that namespace, used as a helper function by the public functions. I've never seen this warning in Clojure. Is this a Clojurescript bug, improperly applying the warning to private calls to a deprecated function?
Hide
Mika Vilpas added a comment -

Was about to open a ticket for this case, but looks like this already exists.

I get this warning in my clojurescript-only application, for example here: https://travis-ci.org/sp3ctum/squanmate/jobs/331680959#L809
However, there is no actual error, only warnings.

Is there something I can do to help? Do you accept patches?

Show
Mika Vilpas added a comment - Was about to open a ticket for this case, but looks like this already exists. I get this warning in my clojurescript-only application, for example here: https://travis-ci.org/sp3ctum/squanmate/jobs/331680959#L809 However, there is no actual error, only warnings. Is there something I can do to help? Do you accept patches?

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated: