<< Back to previous view

[CLJS-572] Aliasing exception when using require-macros Created: 14/Aug/13  Updated: 15/Dec/13  Resolved: 15/Dec/13

Status: Closed
Project: ClojureScript
Component/s: None
Affects Version/s: None
Fix Version/s: None

Type: Defect Priority: Minor
Reporter: Julien Eluard Assignee: Unassigned
Resolution: Completed Votes: 0
Labels: None


When using require-macros with a namespace defining an alias, redefining this alias locally will fail.
This scenario is probably more frequent with library targeting both Clojure and ClojureScript.

I have a reproducing example here.

I also get the same issue without the require-macros when both clj/cljs files are in the same folder. Not sure if this is supported and/or an issue in lein-cljsbuild.

Comment by David Nolen [ 04/Sep/13 11:13 PM ]

Hrm, I wonder if we can actually solve this problem, we need to construct namespaces in Clojure so that the reader can resolve keywords, etc.

Comment by David Nolen [ 05/Oct/13 2:39 PM ]

Was this resolved by CLJS-605?

Comment by Julien Eluard [ 05/Oct/13 7:29 PM ]

Assuming the patch for CLJS-605 is in release 1913, no. I still get the same error message.

Comment by David Nolen [ 05/Oct/13 8:11 PM ]

No CLJS-605 is fixed in master and not available in a release yet. If you have time to test it out that would be great, if not please let us know when we push out the next release. Thanks!

Comment by Julien Eluard [ 05/Oct/13 10:12 PM ]

Still get an error with latest master (1918) but now with a slightly different stacktrace. I updated my gist with the new trace.

Comment by David Nolen [ 11/Dec/13 10:48 AM ]

Is this still a problem given the latest tools.reader?

Comment by Julien Eluard [ 15/Dec/13 4:40 PM ]

No, it now works fine with 2123. Thanks!

Generated at Wed Oct 18 09:36:28 CDT 2017 using JIRA 4.4#649-r158309.